You are not logged in.

Dear visitor, welcome to Last Chaos Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Vilya

Community Manager (en)

  • "Vilya" is female
  • "Vilya" started this thread

Posts: 7,673

Date of registration: 3. September 2014

Location: USA

Occupation: Last Chaos Community Manager

Thanks: 162

  • Send private message

1

Thursday, 30. July 2015, 17:44

Windows 10 Concerns and Issues

We realize that a vast number of our players will be updating to the Windows 10 Operating System. We are gamers, we always try to make things better or easier, find out things tick for our PCs. How to make them faster, game play smoother, or prevent latency and lag issues. We are aware there are some issues that have been arising with this new operating system, and would like to help you..and ask for your help...to make the transition over to Windows 10 smoother for all. So please read below, we welcome all comments ON TOPIC of this thread.

Some facts:

  • We tested LastChaos at gamigo with the Windows 10 RTM Build 10240 which is the final build that matches the live version
  • We played a long time without issues except some loading lags when lots of players were in visual range - this is not caused by windows 10, but because our test-computer was a simple office PC and not a gaming engine
  • We installed Last Chaos after the update to Windows 10
  • We needed to install C++ 2010 Runtime libraries (see this post for links: MSVCP100.dll Missing fix)
  • We did not need to install the .Net 4 framework, as it is part of Windows 10 already
Some ideas that might help (those are not confirmed solutions, but you could try that...)

1) The German Telekom daughter company T-Online released a news about "Windows 10 automatic driver update is incompatible with nVidia GPUs" ( http://www.t-online.de/computer/software…afikkarten.html)
In Windows 10 the automatic update does not only handle parts of the OS, but also hardware drivers. Especially with advanced graphics boards, the installed drivers are not exactly matching the installed hardware. It is recommended to switch off the automatic driver update and use the original drivers provided by the manufacturer of the hardware.

If you like to do that, go to Control Panel -> System -> Advanced system settings -> Device settings ->and check that you want to chose the updates to be installed yourself (menu points may be named differently. would be great if someone who has Windows 10 in the correct language installed could help out by finding the right names of those menus)

2) When updating from an older version of windows, some configuration of previously installed software may get messed up. It is recommended to uninstall Last Chaos completely, manually delete what is left in the installation folder and re-install after the full update

2.a) In some reported cases from other players, it helped to "repair" the game from the installer.

3) Sometimes a so called "deep scan" of some antivirus software may cause the game to close.
Some anti-virus programs use "deep scan" technology and / or try to launch applications in virtual secure containers.
If that is not 100% compatible with Windows 10 and or Last Chaos, it may lead to the application to close.
We recommend to check the settings of your anti-virus software to find out, if there are any technologies actively trying to analyze a
running program. Please do NOT switch off your protection completely. Running a computer without antivirus software is dangerous! Just make sure that the advanced features do not interfere with the game. We cannot support all anti-virus software available. If you do not know how to fine tune your settings, please consult the manual or the support of the anti-virus provider.

We try to dig down to the issues of course, but we may need your help because we just do not experience this kind of issues at our test- environment.
If you have a little knowledge of system protocols, please check the Windows event-log to see if anything is noted there. If you don't know what this is, please just ignore this comment. If you know where to look, please pass any information you may find to our team.

Also, if you find a solution and or work around for this problem on your computer, please be so kind and share the solution with the community and the Last Chaos team.

As always we appreciate your help, cooperation and patience in these matters and will work will all due diligence to fix them as swiftly as possible.

Your Last Chaos Team
Vilya
Community Manager EN/PL
Homepage | Support|
Facebook | Discord Chat
  • Go to the top of the page
  • Activate Facebook

Vilya

Community Manager (en)

  • "Vilya" is female
  • "Vilya" started this thread

Posts: 7,673

Date of registration: 3. September 2014

Location: USA

Occupation: Last Chaos Community Manager

Thanks: 162

  • Send private message

2

Thursday, 30. July 2015, 18:29

Some potential information we might ask for in help to resolve your issue can be found below. You can choose to use this format to post your issue if you wish to save a bit of time, but it is not required, we will do our best to help regardless.

Character name:
Server:
Issue explanation (include what you were doing, where you were, if there was an error code or popup):
Errorlog available (yes or no):

Have you reinstalled LC? If yes, when?
Anti-virus used:

Other Scanner type programs:

Vilya
Community Manager EN/PL
Homepage | Support|
Facebook | Discord Chat
  • Go to the top of the page
  • Activate Facebook

Quest

Newbie

  • "Quest" is male

Posts: 3

Date of registration: 10. July 2015

Location: USA

  • Send private message

3

Thursday, 30. July 2015, 22:21

Character name: Quest
Server:K3
Issue explanation : I can log on and get to spawn pad. Its when I try to move in any direction its game over - back to Windows desktop.

I upgraded to Win 10 on this my desktop and my laptop yesterday. Both worked fine yesterday -then logging in today on the desktop -been having this issue but not on the laptop.
Tried the compatibility function but same results.
Errorlog available (no) Not even a popup - just straight back to desktop window.

Have you reinstalled LC? If yes, when? Deleted game and downloaded everything fine at 15:00 eastern
Anti-virus used: Windows defender for Win 10.


Thanks for any advice or assistance you may have.
  • Go to the top of the page
  • Activate Facebook

Vilya

Community Manager (en)

  • "Vilya" is female
  • "Vilya" started this thread

Posts: 7,673

Date of registration: 3. September 2014

Location: USA

Occupation: Last Chaos Community Manager

Thanks: 162

  • Send private message

4

Friday, 31. July 2015, 00:07

Info from another user:

Quoted



I wanted to share with you some of the results of our tests on Win10:

using a laptop with a version of Win 10 build 10240 We noticed that if the computer is restarted and then we open LC This works well as long as you want.
Then we turned off LC and reopened and it happened again that the game ended after a few seconds.
We rebooted the computer and the game is open and it worked properly, we have closed and reopened and closed again after a few seconds.
We repeated this process many times and the result is always the same.
I do not know if this information may be helpful, but ask you to try it with the computer you have Win10 build 10240, try opening lc close and then reopen it without shutting down or restarting your computer.
Vilya
Community Manager EN/PL
Homepage | Support|
Facebook | Discord Chat
  • Go to the top of the page
  • Activate Facebook

Quest

Newbie

  • "Quest" is male

Posts: 3

Date of registration: 10. July 2015

Location: USA

  • Send private message

5

Friday, 31. July 2015, 16:44

Thank you both, Vilya and the un-named source for the assistance.

LC is up and running fine again. Guess hic-ups like this will be common with Win 10 release for a while.
  • Go to the top of the page
  • Activate Facebook

Vilya

Community Manager (en)

  • "Vilya" is female
  • "Vilya" started this thread

Posts: 7,673

Date of registration: 3. September 2014

Location: USA

Occupation: Last Chaos Community Manager

Thanks: 162

  • Send private message

6

Friday, 31. July 2015, 16:51

I will relay your thanks! Please let us know if there are other issues you come across.

Vilya
Community Manager EN/PL
Homepage | Support|
Facebook | Discord Chat
  • Go to the top of the page
  • Activate Facebook

Posts: 24

Date of registration: 17. July 2015

  • Send private message

7

Sunday, 2. August 2015, 17:03

I'll jsut copy it here :P
I have installed Windows 10 recently(upgraded from windows 7) and it seems like it's having the problems I would on enabling compatibility on Windows 8 or 7,, including the pet problem. I've enabled the compatibility and set to windows 7 to fix it. :P
Also I can't play on fullscreen now, as soon as I change my res back to 1600*900, the game screen goes black and I can't see anything anymore. :P

  • Go to the top of the page
  • Activate Facebook

  • "morbidpoet" is male

Posts: 21

Date of registration: 19. July 2015

Location: Earth ( for now)

Occupation: Nut

  • Send private message

8

Wednesday, 14. October 2015, 03:17

same issue

I am having the same issue did you find a fix for full screen?

Remember its all here because someone wants to make MONEY!!!!!! So free is another word for part of the plans..
  • Go to the top of the page
  • Activate Facebook

divataroza

Rising Star

Posts: 119

Date of registration: 16. July 2015

Location: North

  • Send private message

9

Wednesday, 21. October 2015, 22:07

Character name: DRsKnight
Server: I
Issue explanation MSVCP100.dll missing after upgrading from Win 7 to Win 10
Error log available (yes or no): IDK where it is

Have you reinstalled LC? If yes, when? Oct 20. Fresh download from the home page. All patches went thru. I installed the patch rom the first post.
Anti-virus used: Win 10 default

AP or not AP? (Now IC or not IC?) That is the question...
It is hard to fight armed with that when your opponent is armed like this:
  • Go to the top of the page
  • Activate Facebook

Vilya

Community Manager (en)

  • "Vilya" is female
  • "Vilya" started this thread

Posts: 7,673

Date of registration: 3. September 2014

Location: USA

Occupation: Last Chaos Community Manager

Thanks: 162

  • Send private message

10

Wednesday, 21. October 2015, 22:11

Character name: DRsKnight
Server: I
Issue explanation MSVCP100.dll missing after upgrading from Win 7 to Win 10
Error log available (yes or no): IDK where it is

Have you reinstalled LC? If yes, when? Oct 20. Fresh download from the home page. All patches went thru. I installed the patch rom the first post.
Anti-virus used: Win 10 default
MSVCP100.dll Missing fix
Vilya
Community Manager EN/PL
Homepage | Support|
Facebook | Discord Chat
  • Go to the top of the page
  • Activate Facebook

divataroza

Rising Star

Posts: 119

Date of registration: 16. July 2015

Location: North

  • Send private message

11

Wednesday, 21. October 2015, 22:23

I did that one before I posted, but sill get the missing dll message and can't go past it. Any other suggestions that may help me?

AP or not AP? (Now IC or not IC?) That is the question...
It is hard to fight armed with that when your opponent is armed like this:
  • Go to the top of the page
  • Activate Facebook

Vilya

Community Manager (en)

  • "Vilya" is female
  • "Vilya" started this thread

Posts: 7,673

Date of registration: 3. September 2014

Location: USA

Occupation: Last Chaos Community Manager

Thanks: 162

  • Send private message

12

Wednesday, 21. October 2015, 22:25

Are you certain you used the correct version? (It has worked for everyone else with Windows 10 who has had this issue)

I found a newer versions of that:

https://www.microsoft.com/en-au/download…n.aspx?id=30679


Try this one.

Vilya
Community Manager EN/PL
Homepage | Support|
Facebook | Discord Chat

This post has been edited 1 times, last edit by "Vilya" (21. October 2015, 22:28) with the following reason: Found a newer link

  • Go to the top of the page
  • Activate Facebook