You are not logged in.

Dear visitor, welcome to Last Chaos Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "Newfie0281" started this thread

Posts: 2

Date of registration: 11. November 2017

  • Send private message

1

Saturday, 11. November 2017, 04:07

Extremely low FPS

I just reinstalled Last Chaos, and it is running painfully slow. I've tried turning all of the graphical settings all the way down, and the resolution is currently set to 1280x720.
Any help would be greatly appreciated!


My specs are:
Windows 10 x64 Home
AMD Phenom 1075 x6 3.0Ghz
8gb DDR3 1600
AMD Radeon 6850 2gb
1Tb Windows HDD
2Tb Game HDD

Thanks!!!
Shaynne

  • Go to the top of the page
  • Activate Facebook

Vilya

Community Manager (en)

  • "Vilya" is female

Posts: 7,439

Date of registration: 3. September 2014

Location: USA

Occupation: Last Chaos Community Manager

Thanks: 158

  • Send private message

2

Saturday, 11. November 2017, 14:30

Hello Shayane,

Please go into add/remove program and remove .NET framework, then reinstall it from the Windows website. You should also check for any Windows updates you need to install.

Good luck.

Vilya
Community Manager EN/PL
Homepage | Support|
Facebook | Discord Chat
  • Go to the top of the page
  • Activate Facebook

  • "Newfie0281" started this thread

Posts: 2

Date of registration: 11. November 2017

  • Send private message

3

Saturday, 11. November 2017, 20:42

Turns out I just needed to reboot my computer, lol.
Thanks so much for your reply though!

  • Go to the top of the page
  • Activate Facebook

Vilya

Community Manager (en)

  • "Vilya" is female

Posts: 7,439

Date of registration: 3. September 2014

Location: USA

Occupation: Last Chaos Community Manager

Thanks: 158

  • Send private message

4

Saturday, 11. November 2017, 23:27

You're welcome. I am glad your issue got resolved. Happy gaming!

Vilya
Community Manager EN/PL
Homepage | Support|
Facebook | Discord Chat
  • Go to the top of the page
  • Activate Facebook